To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Out of memory using ETM

MaxUnicamMaxUnicam Posts: 6
I am using the "Mine a Process Tree with ETMd" plugin with a specific event log, but after few minutes of execution an out of memory exception is generated. There are some settings that can help to mitigate this problem? Or there are some known issues? 

Answers

  • hverbeekhverbeek Posts: 456
    Hi,

    Yes, in the ProM Package Manager you can set the amount of memory that the Java VM may use when running ProM. At the bottom, the ProM Package Manager displays a panel like follows:

    Depending on how much memory your computer actually has, some buttons may be added or removed. Here, you can select the amount of memory.

    You can also do this manually by changing the value for the "-Xmx" option in the .bat, .sh., or .l4j.ini file, but using the ProM Pakcage Manager is usually more convenient.

    Kind regards,
    Eric.
    image.png 4.8K
  • JBuijsJBuijs Posts: 912
    If the problem persists after increasing the memory, try reducing the number of generations of the ETMd, or else the population size. You can also try the ETMd Pareto Live version, which will always have the most recent result in case of an error (if I recall correctly).
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • MaxUnicamMaxUnicam Posts: 6
    edited May 9
    In any case, thanks to both!
    Post edited by MaxUnicam on
  • MaxUnicamMaxUnicam Posts: 6
    Ok, I increased the memory limit but this did not solve the problem. After that I setted the population size to 5 and the number of generation to 100 (are these values too small for the goodness of the results?): the plugin does not generate out of memory exception any more but after more than an hour of execution does not end.
  • JBuijsJBuijs Posts: 912
    population of 5 is rather small, I would recommend 10 as the lowest setting, and 2-4 as the 'elite size' minimum.

    If 100 generations take a long time your event log is rather big (mainly in number of activities) so you might try filtering. The ETM is multi-threaded so will make use of multiple CPU cores if possible, if you have another computer with a more powerful CPU this will help.
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
Sign In or Register to comment.