To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

set_BFP: File not found ' NOT INITIALIZEDbfp_etaPFI'

tsengjtsengj Posts: 11
Hi,

Should i be worried about the prompt everytime i run Inductive Visual miner? the Visual miner still runs, but the alignment of logs takes forever on 100 traces on a xeon 8 core 32 gb ram. the prompt in the title above come everytime i toggle the threshold (activities / and path)

thanks,
James

I am running Prom version 6.9 (without jre) on a windows 10 pro 64bit with java version 8 build 1.8.0_221-b11.

Full prompt is as below;
INFO class test.ProduceAprModel2 contains plug-ins.
INFO class com.processmininguc.slog.plugins.ImportSimpleLogPlugin contains plug-ins.
INFO class com.processmininguc.srlog.plugins.ImportSimpleResourceLogPlugin contains plug-ins.
INFO class com.processmininguc.trlog.plugins.ImportTRLogPlugin contains plug-ins.
INFO class com.processmininguc.srlog.plugins.WriteSimpleResourceLogUsingEditorPlugin contains plug-ins.
INFO class com.processmininguc.slog.plugins.WriteSimpleLogUsingEditorPlugin contains plug-ins.
INFO class com.processmininguc.trlog.plugins.WriteTRLogUsingEditorPlugin contains plug-ins.
[PluginDescriptorImpl] Found icon at prom_duck_300.png
INFO class test.FlexValidation contains plug-ins.
INFO class test.ProduceAPr contains plug-ins.
INFO class test.ProduceAprPlugIn contains plug-ins.
Start plug-in Open XES Log File (Naive)
End plug-in Open XES Log File (Naive), took 351 milliseconds
[ActionsBrowser] setFocus
Start plug-in Extract sample of traces (Random)
End plug-in Extract sample of traces (Random), took 4185 milliseconds
Start plug-in @2 Log Summary
End plug-in @2 Log Summary, took 251 milliseconds
Start plug-in Inductive visual Miner
End plug-in Inductive visual Miner, took 8788 milliseconds
LpSolve Libraries Loaded
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'
set_BFP: File not found 'NOT INITIALIZEDbfp_etaPFI'



Comments

  • hverbeekhverbeek Posts: 426
    Hi James,

    There seems to be a problem with your installed LpSolve package. On your machine (WIndows 10, 64 bit), there should be a file called bfp_etaPFI.dll in the lib/win64 folder of the installed LpSolve package. Apparently, this file fails to load, as a result of which LpSolve fails, as a result of which the alignments fail. Why this fails, is hard to say for me.

    For me, the line with the set_BFP looks as follows:

    To me, it seems that the prefix of the path ("E:\...\win64") did not initialize properly on your machine.

    Kind regards,
    Eric.
Sign In or Register to comment.