To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

problem running PromLite

PieterPieter Posts: 2
 I execute the shell script: ./ProMLite12.sh then I get the following output (see attachment) but it doesn't start. This is a recent development.

Answers

  • PieterPieter Posts: 2
    Problem was solved when  I switched to an earlier java version (8) 
  • hverbeekhverbeek Posts: 583
    Hello Pieter,

    ProM Lite 1.2 can be used with Java 9 or higher, but then you need to add the option "-Djava.system.class.loader=org.processmining.framework.util.ProMClassLoader" to the Java VM that runs ProM (see the shell script).

    As from Java 9, the default classloader in Java is no longer a URLClassLoader. ProM uses the URLClassLoader to be able to handle loading the ProM packages correctly.

    But we advice to use Java 8, if possible.

    Kind regards,
    Eric.

Sign In or Register to comment.