Wierd problem. Can't import any log files.

pcoderpcoder Posts: 49
edited October 2011 in - Usage

I have been working on Prom for quite a while now. But, yesterday I encountered this wierd problem. Whenever I try to import a log file into the system, I get an error "Error with import of ...." "java.lang.reflect.InvocationTargetException", and the log file can not be imported.

I have tried removing the packages using the package manger and reinstalling them. I have also tried reinstalling Prom from the scratch. No Idea of what I fiddled, but its really very annoying. I have attached the screenshot herewith.

I would appreciate any help regarding this matter.

Thank you,

Post edited by pcoder on
-- Thank you, PCoder


  • pcoderpcoder Posts: 49
    edited October 2011
    Oops! I didn't notice the change in the interface. We now seem to have three types of plugins to be used for importing, viz. Prom log files, Prom log files(Buffered) and Prom log files (Naive).

    I was always using the first one which led to the error. When I tried the last one (Prom log files (Naive)), the file was imported as desired.

    I am sorry for the silly question. It would be great if someone could point the difference amongst the three.

    Thank you,
    Post edited by pcoder on
    -- Thank you, PCoder
  • JBuijsJBuijs Posts: 922
    Hi PCoder,

    Even though you have other options to import a log file, it is still strange that the default one fails. I always choose this option and for me it (still) works. Did you do any updates?

    If I remember correctly the different variants come from a test discussed in the following blog post by Michael Westergaard (don't get distracted by the other blog posts, I warned ya ;) )

    Hope this helps!!!
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • KritikaKritika Posts: 3

    Same problem occurred with me. I removed the .Prom and UITopia folders. I downloaded ProM source and ran again. This time I ran ProM package Manager.launch and installed "ALL Packages". I think the problem was that some packages were missing. Then I ran ProM with UITopia.launch. Then no such exception came.

Sign In or Register to comment.