To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Conversion of a heuristic net to a petri net

Jo_SwinnenJo_Swinnen Posts: 12
edited December 2011 in ProM5
Dear all,

I have some problems with converting a heuristic net to a petri net. The heuristic net is very simple, but when converting it to a petri net (in ProM 6.1), 5 out of 6 invisible activities are included which are not necessary. Is there a way to solve this?? Or is someone familiar with this problem.

Thank you,

Jo 

Best Answer

  • JBuijsJBuijs Posts: 912
    Answer ✓
    Hi Jo,

    Good to hear that it worked :)
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology

Answers

  • I forgot to include the heuristic net and petri net. Here they are...
  • JBuijsJBuijs Posts: 912
    Hi Jo,

    This is normal behaviour and I think this is caused by the 'default' way a heuristics net is converted to a Petri Net. By always including silent transitions the conversion also works for other cases where more activities are split/joined.

    These silent transitions can be removed using the Murata rules. This is implemented in the plug-in called "Reduce silent Transitions".

    Please let me know if this did the trick!
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • Dear Joos,

    it removes 5 of the 6 silent transitions, but the one that I want to keep is also removed and one that I want to removed, stays. Is there a way to solve this, since you cannot change the settings of the 'reduce silent transitions' plug-in. Otherwise I need to create a petri net manually, and I want to avoid this option.


    Thank you in advance,

    Jo  
  • It worked now! 

    Thank you for your help 

    Jo 
Sign In or Register to comment.