To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Problem connecting to SQL Server

deensethdeenseth Posts: 19
edited March 2014 in - XESame

Hello,

  I am trying to use XESame to connect to the GerritDatabase that is stored in MS SQL Server.  I was able to Test Connection successfully using follwoing infomation

connection string jdbc:sqlserver://localhost\\SQLEXPRESS:1433;databaseName=gerrit;integratedSecurity=true

JDBC Driver com.microsoft.sqlserver.jdbc.SQLServerDriver

Driver Location C:\<path to driver>\sqljdbc4.jar

Connection property User = <windows user name>, password = <password>

When I click Test connection the first time, it passed.  Then I went to Execute Convesion and got following error

2014-03-04 05:05:22: (PROGRESS) Starting step 1 of 6: initialization.

2014-03-04 05:05:37: (ERROR) We could not connect to the data source, we encountered the following error: This driver is not configured for integrated authentication. ClientConnectionId:00cc7ba6-776d-4e47-97df-03857f0a581b

2014-03-04 05:05:37: (ERROR) There is an error in our SQL syntax to connect to the data source. Please contact the XESame developer.

2014-03-04 05:05:37: (ERROR) This driver is not configured for integrated authentication. ClientConnectionId:00cc7ba6-776d-4e47-97df-03857f0a581b

2014-03-04 05:05:38: (ERROR) We could not instantiate a connection to our cache DB. We encountered the following error: Failed to create database 'cacheDB', see the next exception for details.

2014-03-04 05:05:38: (ERROR) It might help to delete the cacheDB dir and try again

2014-03-04 05:05:38: (ERROR) There was an error in our SQL when trying to initialize the cache database.

2014-03-04 05:05:38: (ERROR) Failed to create database 'cacheDB', see the next exception for details.

2014-03-04 05:05:38: (WARNING) Cancelling execution! Just after initialization.

2014-03-04 05:05:38: (NOTICE) Execution safely terminated

 


Answers

  • JBuijsJBuijs Posts: 912

    According to http://stackoverflow.com/questions/6087819/jdbc-sqlserverexception-this-driver-is-not-configured-for-integrated-authentic it might be that you're using a JDBC driver that does not match your java runtime architecture.
    You might want to try another driver.

    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • deensethdeenseth Posts: 19

    Thans Joos.  How can I check which Java runtime XESame is using?  It looks like I have Java\jdk1.6.0_31 folder on both Program Files and Program Files (x86).

    I set my JAVA_HOME to C:\Program Files\Java\jdk1.6.0_31 and JRE_HOME to C:\Program Files\Java\jre6

    There there 2 version of XESame as well? 

    Thanks,

    Deen

  • ratoliratoli Posts: 1

    Although this is an old post, just for the record, the error message seems to be saying don't use integrated windows authentication when connecting to SQL Server. Rather, supply a SQL login username and password instead. That means you need to create the login inside SQL beforehand.

  • nmoallanmoalla Posts: 1

    I'm trying to connect SQL Server in order to fetch traces and I'm facing some problems.

    Could you please review my connection and mapping details

    Thanks

  • JBuijsJBuijs Posts: 912

    Dear 'nmoalla',

    One thing you could try is to not use the properties (remove the user/password keys to remove the property being send while setting up the connection), but put it in the connection string. For me that worked for Oracle databases.

    If this does not help, please provide the error message that you receive, otherwise debugging is rather difficult.

    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
Sign In or Register to comment.