To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

ERROR while scanning for plugins at

royskattroyskatt Posts: 1
edited March 2015 in - Usage

Hello,

this problem has been reported here several times, but no one has been answered so far as I could see. For multiple plugins I get error messages like this:

 

ERROR while scanning for plugins at: file:/C:/Users/michal.meyers/.ProM641/packages/etconformance-6.4.168/ETConformance.
jar:
   in file :org.processmining.plugins.multietc.automaton.AutomatonVis
   edu/uci/ics/jung/algorithms/layout/Layout
java.lang.NoClassDefFoundError: edu/uci/ics/jung/algorithms/layout/Layout
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
        at java.lang.Class.privateGetPublicMethods(Unknown Source)
        at java.lang.Class.getMethods(Unknown Source)
        at org.processmining.framework.plugin.impl.PluginManagerImpl.isGoodPlugin(PluginManagerImpl.java:418)
        at org.processmining.framework.plugin.impl.PluginManagerImpl.loadClass(PluginManagerImpl.java:308)
        at org.processmining.framework.plugin.impl.PluginManagerImpl.scanUrl(PluginManagerImpl.java:221)
        at org.processmining.framework.plugin.impl.PluginManagerImpl.register(PluginManagerImpl.java:153)
        at org.processmining.framework.plugin.impl.PluginManagerImpl.register(PluginManagerImpl.java:133)
        at org.processmining.framework.boot.Boot.addJarsForPackage(Boot.java:279)
        at org.processmining.framework.boot.Boot.boot(Boot.java:177)
        at org.processmining.contexts.uitopia.UI.main(UI.java:96)
Caused by: java.lang.ClassNotFoundException: edu.uci.ics.jung.algorithms.layout.Layout
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)

It happened when copying the .ProM641-Folder from one Windows machine to the other (I have no internet connection on the target machine). Is it maybe because of a different java version?

The program starts but there are missing essential plugins because of that.
Could someone help me out?

Thank you very much in advance!

Post edited by royskatt on
Sign In or Register to comment.