To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Problem with running inductive miner

I use Prom 6.7.

I loaded an CSV file (; seperated) to Prom. The file has 163.000 events in 5000 cases. 

After loading the CSV file I ran the plug in CSV to XES. The CSV parser screen looked fine. I defined the case, event and timestamp. The plug gave a good result.

After that I tried to run the inductive miner. I used two different plug ins: Mine a petri net with inductive miner and Mine the inductive visual miner. Both ran for more than 12 hours without any result (still running, no errors).

What did I do wrong?

Comments

  • Hi Menno, Would it be possible to share the csv file or the generated event log? Kind regards, Sander
    Lecturer at Queensland University of Technology
  • Hallo Sander,

    Thanks for your reaction. I found already what the problem was. It was the mapping of the timestamps (in the default the month and day were defined as one position and the file was 2 positions). 

    Another question: do you know if there are good help files for these plugins. It took me a lot of time to find the issue.

    Thanks, Menno
  • Hi Menno,


    Good to read that you find a way around it :)


    Nevertheless, would it be possible to share the event log, such that we can investigate and solve bugs for other users? It should not run for so long.


    Cheers,


    Sander
    Lecturer at Queensland University of Technology
Sign In or Register to comment.