To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

installation of ProM 6.7

Hi,

I am new in the area of Process Mining. 


I am trying to install ProM 6.7.90.

Sadly the installation of the required packages can not terminated since 
I can not close the dialog and I can not click on the green "OK" button.
So, I am waiting for more than 30 minutes.
That sould not be normal according to the Installation website/ guide.

I already started ProM from the command line and obtained an error (attached).
The other picture (which is also attached to this post) is my screen while
I started the package manager in order to download all packages.


Can you help me? Thank you.


Best,
Richard
error.PNG 9.9K
screen.PNG 103.4K

Answers

  • Hi, the same problem occur to me, I already send an e-mail to Spagnolo but he asnwered me that he change her interest  in research area.

    Who could help? 
    Thansk


    Best,

    Rosângela
  • JBuijsJBuijs Posts: 910
    It seems that the package manager correctly installed the package but now is doing some background work.
    I'll ask my colleague to look into this.
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • hverbeekhverbeek Posts: 319
    Dear Richard, Rosângela,

    Waiting for 30 minutes is excessive, that should indeed not be the case.

    I can think of two reasons for this odd behavior:
    1. Your local packages.xml file has been corrupted.
    2. You have problems accessing the Windows registry.

    1. In the past, we've seen that sometimes, for some unknown reason, the local packages.xml file becomes corrupt, and way larger than need be. This file can normally be found in .ProM67/packages folder in your user folder. Possibly, removing this file and installing all packages again may solve the problem. As an alternative, you could copy the attached unzipped packages.xml file over the existing packages.xml file, as this would not require you to install all packages again.

    2. Possibly, the installation stalls if it cannot access the Windows registry. To avoid ProM from having to scan all packages for plug-ins over an over again, some kind of cache is created in the Windows registry. It is unclear for me why there would be no access, but you might try running ProM as an administrator (if possible).

    The fact that the installation ends with Spagnolo's TraceMatching package does not mean that this package is a problem. ProM indicates that the package has been successfully installed. The TraceMatching package is not to blame here.

    Please let us know whether this helps.

    Kind regards,

    Eric.


    packages.zip 24.2K
  • hverbeekhverbeek Posts: 319
    Dear Richard, Rosângela,

    I've just stumbled on a third possibility. In your ProM.ini, please check the values set for both READ_TIMEOUT and CONNECT_TIMEOUT. My guess is that both are set to 0, which means that ProM will wait forever to read and/or connect. The problem is that one of the images that ProM tries to read does not exist anymore. Apparently, the developer of that package has removed the image without considering the fact that it was still needed.

    Please set both TIMEOUTs to 60000, which sets them to 60 seconds. As a result, the 'endless wait' should be restricted to a minute or so.

    Kind regards,

    Eric.
  • rosangelamariahrosangelamariah Posts: 61
    edited January 2018
    Hi Eric,

    After Change the "ProM.ini" values for READ_TIMEOUT  and CONNECT_TIMEOUT
    I coud download all package, but...

    The ProM are very, very slow to start, I often need to restart my pc.
    Read the file is also so slow, I tried to read a small csv file wih 100 lines and run plugin to generate a model in petri net, it's stay a long time to display the result.
    I did not find the plugin "petri net with inductive miner".

    And the when i opened "ProMPM67.exe" the download started again and stopped in the same point as
    Richard cited.

    Thanks.

    Rosângela 



    Post edited by rosangelamariah on
  • JBuijsJBuijs Posts: 910
    Hi Rosangela Mariah,

    Did you try to download, install, and run ProM lite 1.2? This should be more robust.
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • rosangelamariahrosangelamariah Posts: 61
    edited January 2018
    Thanks Buijs,

    ProM lite 1.2 it's running ok.

    Rosângela 
    Post edited by rosangelamariah on
  • hverbeekhverbeek Posts: 319
    The problem with ProM 6.7 should now be solved.

    The problem was caused by the removal of a package icon. Every package has an associated icon that ProM shows for that package. Typically, this is the ProM icon, but that need not be. For two packages (BPMNMeasures and PetriNetReplayAnalysis), the used icon file was removed, which caused ProM to hang on retrieving the image. The image has now been restored, which solves the problem.

    Of couse, ProM should not hang when an image is missing, and we will change that in future versions. Unfortunately, setting the TIMEOUTs only has an effect on retrieving the package itself, and not on retrieving the package icon (my bad).

    This problems was not restricted to ProM 6.7, but to all versions of Prom that included one of these two packages. This includes 6.7, 6.6, 6.5.1, 6.5, 6.4, ... So, quite a big impact...

    Kind regards,

    Eric.
Sign In or Register to comment.