To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Inductive Visual Miner Plugin not starting

Environment
------------
Windows 10
Java8
Prom 6.8
16GB assigned to PROM

sample of 200 cases
5.5k events

All is installed properly. Updated. 

How should I troubleshoot this? security policy settings??

Inductive Visual Miner Plugin stops as Start Plug-in and doesn't progress further.

But when i tried Plug-in Mine Petri net with inductive miner, that worked.

Example below shows how Plug-in Mine Petri net with inductive miner works,
but when i kick off the Inductive Visual Miner, it doesn't go past Start Plug-in

What am I missing 

>>> Scanning for plugins took 12.287 seconds
>>> Total startup took 19.081 seconds
Start plug-in Open XES Log File (Naive)
End plug-in Open XES Log File (Naive), took 312 milliseconds
[ActionsBrowser] setFocus
Start plug-in Mine Petri net with Inductive Miner
...
End plug-in Mine Petri net with Inductive Miner, took 2519 milliseconds
Start plug-in @0 Visualize Petri net
End plug-in @0 Visualize Petri net, took 263 milliseconds
[ActionsBrowser] setFocus
Start plug-in @2 Log Summary
End plug-in @2 Log Summary, took 163 milliseconds
Start plug-in Inductive visual Miner

and so i removed the folder .prom-graphviz from (C:\Users\xxx\AppData\Local\Temp)

>>> Scanning for plugins took 12.503 seconds
>>> Total startup took 19.64 seconds
Start plug-in Open XES Log File (Naive)
End plug-in Open XES Log File (Naive), took 314 milliseconds
Start plug-in @2 Log Summary
End plug-in @2 Log Summary, took 207 milliseconds
Start plug-in Inductive visual Miner
dot directory C:\Users\xxx\AppData\Local\Temp\.prom-graphviz\dotBinaries7 does not exist; create it and copy binaries to it
copy dot.exe
copy cdt.dll
copy cgraph.dll
copy config6
copy dot.exe
copy fontconfig_fix.dll
copy fontconfig.dll
copy freetype6.dll
copy glut32.dll
copy gvc.dll
copy gvplugin_core.dll
...
copy linux64/dot
copy mac/dot

Comments

  • hverbeekhverbeek Posts: 441
    What now should happen is that ProM starts the dot executable on the file it just created. Apprantely, this does no work as expected.

    The Inductive VIsual Miner creates a .dot file containing the graph to visualize, and calls the dot executable to add the layout to this graph. The graph with the layout is then visualized by ProM.

    Can you check what happens if you visualize the result of the Inductive Miner using, for example,  the "Visualize Petri Net (Dot) (GraphVisualizers)" visualizer in the dropdown menu where you can select the visualization? This also uses the dot executable for the layout. If this visualization works ok, then dot works ok.

    Kind regards,

    Eric.
  • tsengjtsengj Posts: 11
    Yup, the  "Visualize Petri Net (Dot) (GraphVisualizers)" visualizer in the dropdown menu works. 

    I have also reinstalled the Java app (x64 bit). Got nothing. 
  • Hi Tsengj,

    Could you share the log with us? (s dot leemans at qut dot edu dot au)

    Sander
    Sander Leemans
    Assistant Processor (Lecturer) at Queensland University of Technology
    Author of the visual Miner and Inductive Miner
  • tsengjtsengj Posts: 11
    sent. 
  • Hi Tsengj,

    Could it be related to the following Java-bug? https://bugs.java.com/bugdatabase/view_bug.do?bug_id=JDK-8179665

    It should be fixed if Java is updated.

    Hope that would solve it.

    Sander

    Sander Leemans
    Assistant Processor (Lecturer) at Queensland University of Technology
    Author of the visual Miner and Inductive Miner
  • tsengjtsengj Posts: 11
    edited December 2018
    Thanks Sander, I have updated the java to the most recent. In any case bug forum link indicates resolved in 2017. Which is way before i started using PROM. I installed the 6.5.1 version, and the inductive miner works flawlessly. Still troubleshooting why 6.8 doesn't work. 
    Post edited by tsengj on
  • tsengjtsengj Posts: 11
    Inductive Miner worked for me for version 6.5.1 and 6.6. No longer works for version 6.7 on wards on my machine.
  • May I ask to download the latest nightly build (http://promtools.org/doku.php?id=nightly), unzip it, run the "ProM.bat" file, try to run the Inductive visual Miner, and post whatever is shown in the command line?
    Sander Leemans
    Assistant Processor (Lecturer) at Queensland University of Technology
    Author of the visual Miner and Inductive Miner
  • tsengjtsengj Posts: 11
    It is working beautifully now. I have reinstalled the laptop, fresh installed the nightly build, and it is beautiful to see the inductive visual miner again.
Sign In or Register to comment.