Improved support when developing plugins using Java 9 or later

If you are using Java 9 or later for ProM, you are using the ProMClassLoader as the system class loader, as otherwise ProM will crash. Until now, the downside of using this was that the ProMClassLoader did not scan your local project for plugins. As such,m developing new plugins using Java 9 or later was cumbersome.

As from version 6.10.110 of the ProM framework, this restriction has now been lifted: When using the ProMClassLoader as system class loader, the local project will be scanned for plugins. As a result, you can now use Java 9 or later more easily when developing ProM plugins.

Version 6.10.110 of the ProM framework is available as from the ProM Nightly Build of March 31.

When developing ProM plugins using Java 9 or later, please be aware that the ProM continuous build server Hudson still uses Java 8. Whatever you do, make sure that your sources are compatible with Java 8.

 

Leave a Reply